Hilfedatei zu Cadia Warenwirtschaft © by Langwald EDV-Beratung
×
Menü
Index

FastReport-Kurzhilfe

 
Wir möchten Ihnen hier nur eine kleine Unterstützung geben, falls Sie Ihre fr3-Berichtslayouts (Ausdrucke, Formulare...) selbst anpassen möchten,
eine ausführliche Hilfedatei zum FastReport-Designer finden Sie über Menü Hilfe/Fast-Report Hilfedatei.
 
So öffnen Sie den FastReport-Designer zum Anpassen der Drucklayouts:
- über den Aktionenbutton (Drucklayout bearbeiten/erstellen)
- über den FR Button in der Navigationsleite (Bericht im Layout anzeigen)
- (ALT: über den Button Geo-Dreieck in der Navigationsleiste: Bericht im Layout öffnen)
 
Der Fast-Report-Designer öffnet sich:
  Ganz oben im blauen Rahmen wird der Name des Layouts = Berichtsname angezeigt.
 
  
 
Die linke Ansicht ist nur vorhanden, wenn Sie Symbolleisten über Menü Ansicht
eingeblendet haben. Die einzelnen Symbolleisten können Sie auch verschieben oder
über das Sichtfeld legen.
 
OBJEKTINSPEKTOR:
Blenden Sie – wenn nicht vorhanden - den Objektinspektor (F11) ein:
 
 
Reiter Eigenschaften: Mit Klick auf ein Objekt (Feld, Band), zeigt der Objektinspektor
den Namen und die Eigenschaften an. Links ist jeweils die Beschreibung (dzt. Nur in
Englisch, rechts dazu die eingestellte Eigenschaft zum jeweils angeklicken Feld).
 
Die meisten Eigenschaften eines Feldes (oder Datenfeldes) können Sie auch direkt
mittels re-Maus-Klick auf der PAGESEITE verändern.
 
Reiter Ereignisse: auf diesem Feld programmierte Ereignisse (siehe Seite CODE).
Programmiere Ereignisse können auf einem einzelnen Feld liegen, auf einem Band
oder auf der ganzen Pageseite.
 
DATENBAUM:
 
 
Der Datenbaum enthält alle Datenfelder zu einem oder verschiedenen Datasets
(Tabelle, Abfrage).
Die „tablesysdat“ ist die Systemdatentabelle und wird fast in jedem Bericht benutzt.
Die Systemdaten enthalten alle eingetragenen Geschäftsdaten Ihres Betriebes.
Die Felder aus dem Datenbaum können Sie per Drag & Drop in den Report ziehen.
 
 
SEITEN- und RANDEINSTELLUNGEN
 
Die Seiten- und Randeinstellungen, wie viele Spalten Ihr Bericht enthält und auch die
Papierzufuhr (Drucker) wird über die Eigenschaften gelöst:
In den weißen äußeren Berichtsrand mit der re-Maustaste klicken und BEARBEITEN.
Dort kann man auch die Seitenhöhe während der Entwicklung auf Endlos umstellen.
 
FUNKTIONEN / HILFSMITTEL
 
Ganz oben befindet sich das Menü und darunter die Bearbeitungsleiste:
Darin auch ein Button VORSCHAU (wichtig bevor Sie einen Bericht speichern).
 
 
Damit wir Ihnen diese gesamt anzeigen können, teilen wir diese hier in 2 Teile auf:
 
 
wichtig sind die ersten 4 Button:
Neuer Report anlegen - Report öffnen – Report speichern – Report Vorschau(Lupe)
 
darunter finden sich (oben im Bild und unten) die Schrifteinstellungen:
 
 
(im Rahmen) Bündigkeit des Textes, Farbgestaltung
 
 
 
Über die Menüführung ganz links (Bildchenreihe)
 
usw....
 
stehen die einzelnen Optionen für die Gestaltung Ihres Berichts bereit:
Benötigen Sie z.B. ein neues Textfeld oder ein neues Band, können Sie dies von dort über Drag&Drop in den Report ziehen.
 
 
Die Ansicht
 
 
ist in verschiedene Reiter unterteilt.
 
Die Seite CODE enthält bei einem vorhandenen Bericht viele Codezeilen, die den
Druck bzw. die Aufbereitung eines Berichts beeinflussen. Haben Sie keine
Programmierkenntnisse, empfehlen wir hier keine Änderungen vorzunehmen:
 
Die Seite DATA ist nötig, wenn man Felder aus Abfragen oder Tabellen (Datasets)
einfügen will, welche über Menü Report/Daten nicht vorhanden sind. Hier sind
Programmierkenntnisse erforderlich.
 
Die Seite PAGE1 ist die Bearbeitungsseite für das Layout. Hier werden die Felder an
jene Stelle platziert, wo Sie stehen müssen. Später mehr dazu.
 
Die Seiten SUBREPORTS sind definierte Unterseiten und werden generiert, wenn
man auf Page1 einen Unterreport anlegt hat.
 
-------------------------------------
 
A) Sie möchten einen neuen Bericht anhand eines bestehenden Berichts anlegen
B) Sie möchten einen bestehenden Bericht ändern.
 
Neuer Bericht (A):
Öffnen Sie einen bestehenden Bericht und speichern Sie diesen Bericht unter einem
neuen Namen ab (Menüzeile Bericht speichern unter).
Danach können Sie den Bericht abändern:
 
Bestehenden Bericht abändern (B):
Öffnen Sie den bestehenden Bericht, öffnet sich wieder obige PAGE1-Ansicht.
Nun wollen wir Ihnen kurz darstellen, wie diese Page-Ansicht aufgebaut und
bearbeitet werden kann:
 
 
 
Das Layout ist unterteilt in viele Bänder, welche über die Bedienung links miteinander verbunden sind.
Jedes Bank hat einen Namen und enthält
DATENFELDER, FREIE TEXTFELDER, SUBREPORTS etc.
 
In den Bändern liegen die einzelnen Felder (beschriftete) und Datenbankfelder (welche als Platzhalter für die echten Daten dienen). Wenn Sie ein Feld anklicken, zeigt Ihnen der Objektinspektor (links) das Datenfeld dazu an.
 
Viele Felder haben keinen Inhalt. Diese Felder stammen aus der Systemdatenbank (Felder aus Menü Admin./Programmoptionen). Die übrigen Felder stammen aus den Datenbanken im Datenbaum (links).
Der Objektinspektor und der Datenbaum können über das Menü Ansicht ein- bzw. ausgeblendet werden.
 
Texte finden Sie hier nicht vor, wenn, dann sind es meist Überschriften oder fixe Benennungen zu Spalten oder Felder. Diese Benennungen kann man immer abändern (auf Feld doppelt klicken). Felder welche mit einem Datenfeld bestückt sind, sollten Sie nicht abändern, diese kann man aber in dem Band an eine andere Stelle verschieben.
 
Sie können Felder auch mit der rechten Maustaste anklicken und dabei auch grundlegende Eigenschaften ändern.
 
 
SEITENKOPF & SEITENKOPF2FF (ab 2.Seite)
 
Im obersten Band befinden sich alle wichtigen Geschäftsfelder (Firmenkopf) aus den Geschäftsdaten. Hier können Sie Felder verschieben, die Grafik vergrößern.
 
Der schräg-gestellte Text ist der Eindruck „KOPIE“ bei Kopiedruck.
Darunter die Absenderzeile (kommt aus den Geschäftsdaten) und darunter die Adressebild (Anschrift des Kunden).
 
Möchten Sie dieselben Geschäftsfelder auch auf den Folgeseiten andrucken, müssen die Felder auch in das Band Seitenkopf2ff mit aufgenommen werden. Selbstverständlich können die Daten auf den Folgeseiten auch abweichen.
Der Subreport1 enthält in diesem Fall die Referenzdaten zu diesem Beleg (mehr dazu weiter unten).
 
Oben angesprochene Geschäftsfelder stammen aus den Systemdaten „tablesysdat“. Über den Objektinspektor können Sie sehen, welches Feld dann später angedruckt wird.
 
Logo / Grafiken für Geschäftslogo / Unterschrift
 
Bei Bildern empfehlen wir, diese so zu speichern, dass die Auflösung gut ist, aber das Bild keine enorm großen Maße aufweisen (Ladezeiten beim Versand, beim Druck vergrößern sich). Das Bild (Logo) sollte auch keine unnötigen weißen Ränder enthalten.
Das Logo (oder die Unterschrift) müssen Sie im Layout von der Größe her so einrichten, dass Sie Ihren Vorstellungen entspricht.
 
Grafik als Hintergrund: (Backpicture gemäß Objektinspektor)
 
Sie können auch Grafiken als Report-Hintergrund laden.
Bitte beachten Sie, dass große Grafiken die Ladezeiten enorm vergrößern und sich
die Größe bei PDF-Aufbereitung enorm ausdehen.
Alternativ können Sie ganze Bänder farblich einfärben oder kleinere Grafiken
verwenden.
 
.ANREDE
in dem Band Anrede befindet sich die Briefanrede.
 
KOPFDATEN / KOPFZEILE
in dem Band Kopfdaten befindet sich der Kopftext des Beleges (lt.
Programmoptionen)
 
SPALTENÜBERSCHRIFTEN
in den Spaltenüberschriften befinden sich die Überschriften zu dem folgenden
Masterdata.
und in der Rechnung auch ein berechnetes Summenfeld (Code).
 
MASTERDATA
Das wichtigste Band in einem Report ist das Masterdata (orange Leiste).
mit den Hauptdaten zum Beleg, welche mit den Daten aus dem queryRPT gespeist werden. Das Dataset „queryRPT“ enthält alle Positionen einer Rechnung, samt der Menge, der Mengenart, Einzelpreis (Preis vor Rabatt), MWSt.-Satz, Endsumme (berechn. Feld=Code).
Selbstverständlich können Sie hier Felder vergrößern oder verschieben oder evt. über das Kontextmenü ausblenden.
 
CHILD: (Unterbänder; jedes hat einen anderen Namen)
unter dem Masterdata befinden sich sogenannte„Childbänder“, Datenbänder, welche eigentlich
zum obigen Artikel gehören, z.B. Seriennummer, Lieferzeitpunkt, etc.
Die Child-Bänder werden dank der Codes auf der Codeseite nur gedruckt, wenn Inhalte vorhanden sind, sonst werden sie weggeblendet und verbrauchen keinen Platz.
Childbänder sollten auf der PAGE1 das Merkmal „nicht zusammenhalten“ bekommen,
in Subreports jedoch schon.
 
  
   Jedem Band kann man Child-Bänder anhängen und jeweils mit dem darunterliegenden verbinden (Eigenschaften/Child > das darunterliegende Child wählen).
Das Merkmal „PrintChildInvisible“ sollten Sie auf TRUE setzen.
Wenn Sie mehr Text in einem Child unterbringen möchten, dann sollten Sie das
Merkmal „Dehnen“ wählen, damit sich das Band auch vergrößert.
 
--------------
 
Hier beschreiben wir jetzt die 3 verschiedenen Feldtypen:
 
DATENFELDER
 
 
 
 1 = Datenfeld aus Datasets (aus Tabellen und Abfragen)
im umrahmten Feld wird das Dataset und der Feldname direkt angezeigt.
Die Schriftart- und die –type muss hier festgelegt werden.
 
2 = freies Textfeld (kann als einzelnes Feld oder direkt vor das Datenfeld gesetzt
werden (mit Doppelklick in Datenfeld und vor dem Wert setzen)
 
3 = RTF-Datenfeld, wo die Schriftart bereits vorgegeben ist (z.B. Kopftext lt. Programmoptionen):
Diese Felder erkennt man daran, dass sie keinen Text enthalten, aber umrahmt sind.
Welches Feld dahinter steckt ? Klicken Sie es an und es wird im Objektinspektor angezeigt.
 
 
 
mit CODE belegte FELDER
 
 
Kleine rote Pfeilchen auf Bändern oder Datenfeldern sagen aus, dass auf diesem
Feld ein Ereignis (ein Programmcode) liegt. Bevor Sie also ein Feld löschen, prüfen
Sie den Code, der dahinter steckt (Objektinspektor/Ereignisse).
Um Platz zu sparen oder Ressourcen im Ausdruck zu sparen, kann man jedes Feld
klein (schmal) schieben (Beispiel siehe Spaltenüberschriften).
Wenn der Bericht alle nötigen Datenfelder enthält, können Sie beginnen, den Bericht
nach Ihren Wünschen anzupassen.
Fangen Sie damit oben an (Seitenkopf und gehen Sie danach bis unten durch).
 
 
Die noch nicht besprochenen Bänder folgen jetzt:
 
FOOTER:
Der Footer enthält die Summen zum MasterData.
 
ZAHLUNGSBEDINGUNGEN:
ist ein Datenfeld, Schrifttype hier anpassen.
 
SKONTOBEDINGUNGEN:
Subreport s.u., gemäß Skontodaten unter
Grundeinstellungen/Zahlungsbedingungen.
 
SCHLUSSBEMERKUNGEN:
ist ein RTF-Datenfeld, enthält die Daten aus dem Beleg.
 
GRUSS:
ist ein RTF-Datenfeld, enthält die Daten aus dem Beleg und die Grafik aus den Geschäftsdaten bzw. Mitarbeiter.
Wenn Sie die Grafik löschen, müssen Sie auch den zugehörigen Code löschen.
 
TEXT AKTUELL:
ist ein RTF-Datenfeld enthält die Daten gemäß Programmoptionen
 
------------------------------
 
SUBREPORTS:
 
Alle Daten aus den „Subreports“ (eigene Unterreports) können natürlich auch einzeln direkt in den Bericht
(z.B. in Childbänder) gezogen werden und so wie die übrigen Childbänder behandelt
werden (ein- und ausblenden).
Subreports können auch in andere Regionen auf dem Report verlagert werden,
probieren Sie es aus.
 
Wenn Sie einen Subreport löschen, löschen Sie bitte dazu auch die jeweilige Unterseite. Die würde sonst in der Luft hängen und die Darstellung beeinflussen.
 
 
-----------------------------
 
PAGE FOOTER (Fußzeile)
 
Der Pagefooter ist das einzige Band, das sich nicht automatisch vergrößert. Haben
Sie also viel Text in den Fußzeilen erfasst, sollten Sie diesen Bereich komplett größer ziehen
(markieren und an den Randmarkierungen mit der Maus ziehen). Hier können Sie
auch einstellen, ob die Datenfelder auf
 
* der ersten Seite
* auf der letzten Seite (bzw. Folgeseiten)
 
gedruckt werden sollen.
 
Die Daten für den Pagefooter werden in den Programmoptionen/Reiter Geschäftsbogen eingetragen. Die kleinste Schrift gemäß Navigation wäre 8er Font. Wünschen Sie eine kleinere Schriftgröße (7, 6, 5) , markieren Sie den Text im jeweiligen Fußfeld und ändern über das re-Maus-Menü über SCHRIFT die Größe entsprechend ab.
 
==================================================
 
 
Wenn Sie Anpassungen selbst vornehmen, speichern Sie den Bericht zwischendurch immer wieder ab (Bericht speichern unter).
Über die Berichtsvorschau können Sie einen abgeänderten Bericht überprüfen.
Kommt ein Fehler schon in der Vorschau, dann machen Sie die letzte Änderung rückgängig oder speichern Sie den Bericht nicht mehr ab.
Ist ein Bericht kaputt, löschen Sie den Bericht im ZentralenBerichteVerzeichnis (Unterordner von Cadia\Daten) und rufen dann das Layout neu auf. So wird der ursprüngliche Bericht immer wieder neu geladen.
---------------------------
 
Fast alle Felder kann man verschieben.
Viele Felder können nur in einem Band hin- und herbewegt / verschoben werden.
Komplette Bänder sollte man nicht verschieben, mit Ausnahme von Childbändern.
Childbänder sind immer mit dem vorherigen Band verbunden; daher vorher lösen; dann wieder neu verbinden.
Datenfelder oder Textfelder können angeklickt und dann verschoben oder auch vergrößert/verkleinert/verschmälert werden.
 
Felder (mit rotem Häkchen) enthalten einen Code, auch Summenfelder werden berechnet: Wenn Sie ein solches Feld verschieben, welches über das Programm berechnet wird (z.B. ein Summenfeld), dann kann dies dazu führen, dass die
Berechnungen nicht mehr richtig und gar nicht ausgeführt werden können.
 
Felder, welche sich aufgrund der Textlänge vergrößern lassen müssen, sollten in ein eigenes Band abgelegt werden. (z.B. Briefanrede1)
Wenn sich Felder vergrößern, dann sollte das Band und auch das Feld die Eigenschaft „Dehnen“ erhalten. Zu Setzen im Objektinspektor oder über das Kontextmenü (re-Maus-Menü).
Über dieses Kontextmenü können Sie auch für Bänder oder Felder die „Aufteilung erlauben“.
 
Das bedeutet, dass ein längerer Text z.B. über 2 Seiten aufgeteilt wird oder ein Text, wenn er sich nicht mehr auf der ersten Seite ausgeht, auf der 2. Seite fortgesetzt wird.
 
Achtung! Bei Berichten, wo Überträge vorhanden sind (fast alle aus Ein- und Verkauf) kann diese Aufteilung nicht zugelassen werden, weil sonst die Berechnung des Übertrags (Summenübertrags) nicht mehr funktioniert.
 
Das Kontextmenü enthält noch weitere sinnvolle Einstellungen, z.B. Sichtbar, Druckbar, nach Vorne setzen, nach Hinten setzen…. Etc. Und Einstellungen für die Grafiken/Bilder (Zentrieren, Mittig…)
 
Wird z.B. im PDF ein Feld nicht angezeigt, muss es „nach vorne“ gesetzt werden.
 
 
GESPERRTE FELDER
 
Können Sie ein Feld nicht löschen, dann ist es vielleicht gesperrt. Über den Objektinspektor „Restrictions“ können Sie die Sperre aufheben (True=Wahr, False=Falsch).
 
 
CODE LÖSCHEN
 
einen Code zu löschen, kann bedeuten, dass der gesamte Bericht nicht mehr funktioniert. Entfernen Sie also einen Code, lassen Sie sich direkt immer die Vorschau anzeigen.
Funktioniert die Vorschau nicht, machen Sie es bitte rückgängig oder speichern Sie den Bericht nicht mehr ab.
Anstelle von Löschen, können Sie vor die jeweilige Codezeile auch 2 Schrägstriche (//) setzen, somit wird der Code außer Kraft gesetzt.
 
===============================
 
 
Tipp: Möchten Sie diese Änderungen nicht selbst vornehmen, beauftragen Sie das Cadia-Team mit diesen Änderungen/Anpassungen.